Comment mettre à jour vers PHP 7.4 pour le site WordPress sur Debian 9

Dans cet article je vais vous montrer comment j’ai réussi à mettre à jour PHP 7.4 pour mon site WordPress. J’exécute certains de mes sites WordPress en plus de Debian 9 Stretch. J’avais cette notification sur le tableau de bord WordPress indiquant que je devais mettre à jour mon PHP vers la dernière version. J’utilisais PHP 7.0 sur mes sites.

Vous découvrirez comment mettre à jour manuellement votre installation PHP vers la version 7.4. Vous verrez également comment résoudre ce problème de «mise à niveau PHP requise» sur un site WordPress.

MAJ Système

Il est recommandé de mettre à jour le système Debian avant la mise à niveau.

apt update && apt upgrade

Configurer le référentiel PHP 7.4

Exécutez la commande suivante pour installer certains packages et télécharger la clé gpg pour le référentiel Sury.

apt -y install lsb-release apt-transport-https ca-certificates
wget -O /etc/apt/trusted.gpg.d/php.gpg https://packages.sury.org/php/apt.gpg

Enfin, utilisez cette commande pour ajouter le référentiel

echo "deb https://packages.sury.org/php/ $(lsb_release -sc) main" | tee /etc/apt/sources.list.d/php.list

Ensuite, mettez à jour le système

apt update

Installez PHP 7.4 sur Debian 9

Utilisez cette commande unique pour installer PHP7.4 sur Debian 9

apt install php7.4

Maintenant, vérifiez à nouveau la version PHP à l’aide de la commande php -v et vous devriez voir que la nouvelle version est installée comme suit

Installer des modules PHP

Copiez et collez ces commandes pour installer certains modules PHP7.4 nécessaires à WordPress.

apt install -y php7.4-common php7.4-xml php7.4-mysql php7.4-pdo php7.4-phar php7.4-simplexml php7.4-curl php7.4-mbstring php7.4-imagick php7.4-zip php7.4-gd

Désactiver le module PHP 7.0 et Activer le module PHP 7.4

Alors maintenant, nous allons désactiver l’intégration Apache PHP7.0 et activer le php7.4.

a2dismod php7.0
a2enmod php7.4
systemctl restart apache2

Maintenant, connectez-vous à nouveau à WordPress et le problème devrait être résolu. Votre installation PHP est maintenant à jour et vous ne voyez plus l’erreur «Mise à jour PHP requise».

Laisser un commentaire